SAT Practice page not loading correctly
Incident Report for Khan Academy
Resolved
SAT Practice page is up and running again.
Posted Oct 08, 2022 - 20:35 PDT
Identified
We have identified an issue the SAT Practice page is not loading correctly.
Posted Oct 08, 2022 - 09:24 PDT
This incident affected: Test Prep (SAT).